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CT6xx Series Introduction

Scope
There are three manuals for the CT6xx Series; 

(1) CT6xx Series Reference Manual

(2) CT6xx Series Software Development Manual

(3) CT6xx Series Quick Start Guide

The content of this document is intended as a quick start for developers as they begin to work with 
the CT6XX. The system integrator is responsible to provide specific operating instructions and 
manuals for end users. 

CT6xx Series General Description
The CT6 Series (referred to as the CT6xx) is a rugged, sealed, tracking and communication device 
intended for the vehicle market. It is an open architecture device, programmable with industry 
standard tools. It incorporates a powerful ARM-based processor, multiple communication ports, 
and digital inputs/outputs. In addition, it can include GPS, GSM/GPRS and CDMA 1xRTT. It also 
can include a built-in UPS to sustain operation during short interruptions in power. With its power 
supply sensing input, enough time is available for the application to store critical data and put the 
unit in a low power mode to prevent the loss of data and prevent the corruption of the application.

Note: Reference to the CT6 Series or CT6xx may also include OBC605, which is a limited-feature 
version of the product family.

Development Disk
A CD containing the files discussed in this document is available from Dyacon. Refer to the 
CT6xx Series Software Development Manual and the CT6xx Series Reference Manual for 
additional information.
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CT6xx Series Development Kit
For first time developers, the CT6XX typically ships out as a kit that includes the following:

Item Description

CT6xx CT6xx Series Device

CT6 BOB Break-Out Board for ease of development

Power Brick 110 AC in / 12 V DC out that connects to the CT6 BOB

Null Modem Cable Used to connect the CT6 BOB to a host computer via 
serial port

Development Tools CD Developers Tools disk also referred to as Utility Disk

Connection Cables Set of Power/IO cables (opetional)

Development Tools Disk (Utilities Disk)
The development tools disk includes the following:

Tool Description

OBCLink OBCLink is a windows-based utility program used to 
communicate between the CT6 and the host computer.

GNU X-Tools 30-day evaluation of the GNU X-Tools by Microcross.

VX-Tools Visual X-Tools

CT6 Tools Various example programs with source code. Also 
manuals and support documentation.
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Development Tools Disk Folders
Following is a partial listing of where to find some useful information after the installation has 
been completed. (Assuming that the default settings are used when installation takes place.)

Path Description

C:\cygwin Main folder includes the GNU General Public 
License document.

C:\cygwin\docs Contains documentation for the Microcross tools 
including libraries, utilities, compiler tools, 
debugging tools, etc.

C:\cygwin\home\obc605 Folder containing documentation, examples, and 
utilities for the CT6XX. 

C:\cygwin\home\obc605\docs\ CT6XX Manuals.

C:\cygwin\home\obc605\TestPrograms\

                                                           

Includes source listings of various examples 
including examples for the CDMA cell phone, 
GPS, J1708, RS485, a terminal example and a 
timer example.

C:\cygwin\home\obc605\utilities\ OBCLink.exe utility program, initab file, and Jload
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CT6xx Tools  Installation

Development Tools Installation 
The CT6XX development tools disk is designed to auto run when it is placed in a CD drive. 
Following are the basic instructions:

1. Insert the CT6xx Development Tools (Utilities) CD into your PC (host 
computer).

2. The disk should auto run. If not, open files on the disk and execute setup from 
the root directory. Follow the installation instructions on the host computer.

3. Click Next to continue with the installation.

4. Click the “I accept the terms in the license agreement.” Click Next to continue.
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5. Key in the desired User Name and Organization and select the desired 

installation. Click Next to continue.

6. Use the default destination folder or click Change to install to a different folder. 
Click Next to install to the selected folder. 
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7.  The wizard is ready to begin installation. If you want to review or change any of 
your settings, click Back. Click Install to continue.

8. Depending upon the type of computer being used, the installation may take 
several minutes. 

9. When complete, click Finish to exit the wizard.
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10. To install Visual X-Tools execute setup from the following folder: 

VXTools\ 

11. Click Next to begin the installation wizard.

12. Please read the license agreement carefully, select “I accept the terms in the 
license agreement,” and click Next to continue.
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13. Read the Readme information and then click Next to continue.

14. Key in your User Name and Organization and select the desired method of 
installation. Click Next to continue.

15. Use the default destination folder or click Change to install to a different folder. 
Click Next to continue.
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16. To review or change any of the installation settings, click Back. Click Install to 

begin the installation.

17. When the installation has completed, click Finish.
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OBC Tools  Installation

OBC Tools Installation
The purpose of the Tools installation is to provide test programs and utility files needed for 
interfacing with the CT 6xx. The location of manuals are also included in this section. The only 
relevant folder is the TestProgams folder. The location of this folder is of importance when 
running the compiler tools. Other folders can be either left on the disk or copied onto the local 
drive at a location of your convenience. The following procedures outline where to place the 
TestPrograms folder:

1. On the local drive, find C:\cygwin\home\.

2. Copy the TestPrograms folder from the Developers (Utility) disk located under the 
obc605 directory to the location designated in step 1.

3. Copy the Utility and Docs folders under the obc605 directory on the Developers CD 
to a desired location on your hardrive.

Installation of all the tools has now been completed. It is also possible to run the installation programs again to 
modify or uninstall the programs. Note that if uninstall is used, it may take a few minutes for the installation to 
complete because of the size of the X-Tools environment and number of files to be uninstalled. You will also 
need to manually remove the directories copied in this section.
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Hardware Setup

1. In a static free work area, remove the CT6XX PCBA from its case (use a flat 
head screwdriver to release the latches on each side of the case). 

2. Place the CT6XX PCBA into the CT6XX BOB as shown below 

CAUTION:

Make sure that the CT6XX PCBA is inserted into the CT6XX BOB correctly, as 
shown below. Inserting the PCBA backwards can cause damage to the CT6XX 
PCBA and to the CT6XX BOB.

3. Connect the Console port on the CT6XX BOB to the PC’s serial port with a null 
modem cable.

4. Having the CT6XX BOB’s On/Off switch in the OFF position, connect power to 
the CT6XX BOB using the power brick or an alternative 12V source. 
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OBCLink

Using OBCLink
OBCLink allows the host computer to communicate with the CT6XX. Files can be transferred 
back and forth between the CT6XX and host computer. CT6XX shell commands can also be 
issued from the host computer.

1. Run OBCLink.exe, which can be found in the Utilities folder of the obc605 
folder on the Developers (Utilities) CD. Refer to the OBCLink section of the 
CT6XX Series Reference Manual for additional details on how to use the 
program.

2. Configure the COM port by clicking on the Properties button (sixth button from 
the left). Select the desired COM port and baud rate. The default baud rate for 
the CT6XX is 38400. Units are shipped with a standard configuration “initab” 
file that changes the baud rate to 115200.

3. Click the connect button (fourth button from the left).

4. Assuming that the CT6XX has been placed in the CT6XX BOB and everything 
has been connected properly as outlined in the previous section, apply power to 
the CT6XX by switching the switch on the CT6XX BOB to the On position. The 
red and green LEDs on the CT6XX PCBA briefly flash. Boot information is 
displayed in the OBCLink work area and the cursor should be on the prompt 
“#:”
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5. Shell Commands can be issued at the command prompt. Following are a few 
examples:

At the command prompt:

Key in “help” to display a listing of all the commands available.

#help
Command Set:
call        cat         cp          date        dchk        defrag 
df          echo        edit        exit        finfo       flash 
fsize       gosub       goto        gpio        help        history 
if          item        ld          ls          mem         read 
reset       return      rm          rs232       run         set  
delay       time        tfs         sleep       suspend     sysinfo  
plvl        version     watchdog    xrcv        xsnd
     

Individual command help can be displayed by keying in help followed by 
the specific command, for example, key in “help ls” to view the help for the 
list command. Refer to the CT6XX Series Software Development Manual 
for information regarding the shell commands.

#help ls
List the current set of files in the file system
Usage: ls [-almx] [[filter] [filter...]]
Options:
 -a    display 'hidden' files
 -l    long format
 -m    enable more
 -x    set exit flag if error
Required privilege level: 0

#sysinfo

TOS 1.3
Platform: Wescor OBC605
CPU: MC9328MXL ARM920T
Built: Feb  6 2007 @ 14:00:15
Stack: bottom=0x80d57bc, size=16384 (10% used)
API Entry Addr: 0x20
TOS RAM: 0x807d000-0x80d9d64
App RAM Base: 0x8100000
#
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Visual  X-Tools  Example Program

Assumptions
• GNU-X-Tools is already installed

• VX-Tools is already installed

• OBCTools is already installed

• User has a basic understanding of the development process for the 
CT6XX

Visual X-Tools Example Program
1. Execute Visual X-Tools. 

2. Select Demo mode & continue when prompted to install demo version 

NOTE: When asked to exit the program, click OK. The demo version will 
continue to operate.

3. From the main menu, select Project->New… 

4. In the Project tab select “GNU arm-elf C/C++ Wizard”, enter the project’s name 
(i.e. hello) and enter the location (path) where the project should be created (i.e. 
C:\cygwin\home\Obc605\examples\hello\). Click the OK button.
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5. In the Create dialog box, select Executable for Project Type and C for source 

Type. Click Next to continue.

6. In the next dialog box select A “Hello World” application and click Next.

7. From Build System, select the “Build with an auto-generated, auto-maintained 
makefile,” leave the makefile name blank (default) and click Finish.
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8. At this point the “New Project Information” dialog should be presented. Click 
the OK button to accept the choices.

9. The project’s environment needs to be set up so the correct tools are invoked to 
generate the executable. Follow the steps to incorporate the Strip command 
found in the “Adding the Strip command to the Build menu” section later is this 
manual.

10. From the main menu, select the “Build->GNU C X-Tools Options..,” In the 
“Code Generation” tab, select “Med(-O2)” for the Level of optimization.
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11. In the Link tab, set it as follows:

12. In the Warnings tab, select “Show all warnings.”

CT6 Quick Start 18



DYACON, IncDYACON, Inc

13. In the Misc tab expand the “Language” option and select “-fno-builtin.”

14. Expand the “Machine” option and under “arm-elf” find and select “-
mcpu=arm9tdmi”. Click the OK button to close the dialog box.
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15. The OBC605 header file needs to be included. Change the program’s “include” 
statement as follows:

16. Click the Build button to generate the hello executable.

17. Once the binary is generated, strip the program of unnecessary information so 
that the binary is smaller (this step is not required, but it makes the binary about 
25% smaller). To do this, select Build->Strip from the main menu. See “Adding 
the Strip Command” on the following page. (If the default folder settings were 
used, the binary file is located in the debug folder, 
C:\cygwin\home\obc605\examples\hello\debug\.)

18. Follow the steps later in this manual in the “Adding a button to the Build toolbar 
to invoke OBCLink” section. 

19. Invoke OBCLink (click the OBCLink button in the Build Toolbar).

20. Connect the host computer to the CT6XX as was described in the “Hardware 
Setup” section of this manual. 

21. If the CT6XX is not already powered on, apply power to the CT6XX and click 
the “connect” icon.

22. Drag and drop the program “hello” to the work area of OBCLink 
C:\cygwin\home\obc605\examples\hello\debug\hello (upload it as an executable 
file).

23. From within OBCLink, run the “hello” program by keying in the file name hello 
from the command prompt. Hello and welcome to the world of Visual X-Tools\n 
should be displayed in the work area of OBCLink.
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Adding tools to the vx-tools environment

Adding the Strip command to the Build menu
1. From the main menu select Project->Project Properties…

2. In the Tools tab, click the New.. button to create a new tool entry.

3. In the New Project Name dialog box enter the word “Strip” (omit quotes) and 
click the OK button.

4. At the Command Line enter “arm-elf-strip %rp%bd%on” (omit the quotes). 
Select Capture output and Output to process buffer, and click the OK button.
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Adding a button to the Build toolbar to invoke OBCLink
1. Right click the Build toolbar and select Toolbars…

2. In the Categories tab, select “User Definable Tools” under categories.

3. Drag the first icon to the Build toolbar and then click the Close button to dismiss 
the dialog box.

4. Right click the new tool button and select Properties… from the popup menu.

5. In the Toolbar Control Properties enter the path and name of the OBCLink 
program and in the Message space enter “Open OBCLink Window” (omit the 
quotes). Click the OK button.
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Manual  History

February 2007
Initial release of the CT605 Series Quick Start Guide.

November 2007
Made minor corrections to the manual.

Updated with Dyacon Inc.

July 2008
Converted to Dyacon name.

April 2009
Adapted Manual to cover entire CT6 series
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